const regex = /<\s*(inverse|reverse|repeat)\s*(?:value\s*=\s*"(\d*)")?\s*(?:content\s*=\s*".+?")\s*>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*(inverse|reverse|repeat)\\s*(?:value\\s*=\\s*"(\\d*)")?\\s*(?:content\\s*=\\s*".+?")\\s*>', 'g')
const str = `<inverse content="HelloWorlD"/>
<reverse content="helloworld"/>
<reverse content="helloworld"/>
<repeat value="2" content="helloworld"/>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}