// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<\s*(inverse|reverse|repeat)\s*(?:value\s*=\s*"(\d*)")?\s*(?:content\s*=\s*".+?")\s*>"#).unwrap();
let string = "<inverse content=\"HelloWorlD\"/>
<reverse content=\"helloworld\"/>
<reverse content=\"helloworld\"/>
<repeat value=\"2\" content=\"helloworld\"/>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}