Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
[0-9]+[ \t\r]+(\w|\.|\-)+[ \t\r]+[0-9]+([ \t\r]+(\w|\.|\-)+[ \t\r]+\-[ \t\r]+\w+|)(\n|\r|)+
/
g
Test String
New
0 coralxib42 0 coralxib42-ib0 - MEMBER 1 coralxib43 0 coralxib43-ib0 - MEMBER 128 coralxib44 0 coralxib44-ib0 - CF 129 coralxib45 0 coralxib45-ib0 - CF 0 coralpib241 0 - - MEMBER 1 coralpib242 0 - - MEMBER 128 coralpib243 0 - - CF 129 coralpib244 0 - - CF cskd;ksd ksalkd;lksakd sad'lj 020 - 29 0 coralpib241 0 1 coralpib242 0 128 coralpib243 0 129 coralpib244 0