using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*([\s\S]*?)\*\/";
string input = @"{
This is line 1
/*This is line 2
This is line 3
This is line 4*/
This is line 5
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}