$re = '/\/\*([\s\S]*?)\*\//';
$str = '{
This is line 1
/*This is line 2
This is line 3
This is line 4*/
This is line 5
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);