import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:Copy of )?(?P<showName>.*?)(?: - )?(?P<episode>S\\d\\dE\\d\\d)$";
final String string = "Bleach S01E02\n"
+ "Attack on Titan S03E03\n"
+ "Bleach - S11E12\n"
+ "Attack on Titan - S19E20\n"
+ "Copy of Attack on Titan - S10E10\n"
+ "Copy of Bleach - S01E02";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}