import re
regex = re.compile(r"^(?:Copy of )?(?P<showName>.*?)(?: - )?(?P<episode>S\d\dE\d\d)$", flags=re.MULTILINE)
test_str = ("Bleach S01E02\n"
"Attack on Titan S03E03\n"
"Bleach - S11E12\n"
"Attack on Titan - S19E20\n"
"Copy of Attack on Titan - S10E10\n"
"Copy of Bleach - S01E02")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")