use strict;
my $str = 'tagcatch 1/tag
tagcatch 2/tag
tagcatch 3/tag
Only catch above this
tagcatch 4/tag
tagcatch 5/tag
tagcatch 6/tag';
my $regex = qr~(?s)tag(.*?)/tag(?=.*\bOnly catch above this)~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}