$re = '/\D+(\d+)/';
$str = '"PlusContent"
"PlusArchieve"
"PlusContent1"
"PlusArchieve1234"
"PlusArchieve123"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);