# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(http(s)?:[/]{2})?([a-z0-9][a-z0-9\-]+.)+([a-z0-9\-])+"
test_str = ("http://aaa.com.tw\n"
"https://aa-a.com.tw\n"
"http://aaa.com\n"
"https://aaa.com\n"
"aaa.com\n"
"aaa.com.tw")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.