const regex = /^\d+\s<([A-Z]+)>\s(\d+\s)(\2)+<\/(\1)>$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+\\s<([A-Z]+)>\\s(\\d+\\s)(\\2)+<\\\/(\\1)>$', 'gm')
const str = `1234 <CIRCLE> 12 12 12 </CIRCLE>
1234 <RECTANGLE> 12 12 12 12 </RECTANGLE>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}