using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(-?\d){10,14}$)3[0-9-]{9,18}$";
string input = @"312345678
312345678912345
3-12345678
3-12345678912345
3-1-2-3-4-5-67891234
12345678901
3-1-23456789
3-1-2-34567891234
3123456789
31234567891234
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}