$re = '/^(?=[0-9-a-zA-Z]+$)(.).{4,}(?!\1)./m';
$str = 'abcde
abcdef
abcdea
abcdefg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);