using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\s\S]*\K(<p>)";
string input = @"<p>First paragraph</p>
<p>Second paragraph</p>
<p>Third paragraph</p>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}