# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^=]+)=(\d+)\n(.*?)\1=\d+/$3$1=$2/;t' <<< "test2=5
test=39&test2=4&test3=10"