const regex = /^([^=]+)=(\d+)\n(.*?)\1=\d+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^=]+)=(\\d+)\\n(.*?)\\1=\\d+', '')
const str = `test2=5
test=39&test2=4&test3=10`;
const subst = `$3$1=$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);