$re = '/^([^=]+)=(\d+)\n(.*?)\1=\d+/';
$str = 'test2=5
test=39&test2=4&test3=10';
$subst = "$3$1=$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;