package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s).*(<table>.*?<\/table>)`)
var str = `<div>
<table>1<table>
<table>2</table>
<table>3</table> - i need this one and all its contents
<div>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}