$re = '/.*(<table>.*?<\/table>)/s';
$str = '<div>
<table>1<table>
<table>2</table>
<table>3</table> - i need this one and all its contents
<div>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);