import Foundation
let pattern = #"^(\d{4})\d(?=\d{4})|\d(?=\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123467671234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1X"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)