using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<! ) (?! )";
string substitution = @"_";
string input = @"'SYS W$_FIasdfLESTATXS TABLE PARTITION 0 '";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}