re = /^(?!.*_).*\.txt$/m
str = 'somepath/testFile.txt
somepath/testFile_test.txt
somepath/testFile.txtTEMP'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end