import Foundation
let pattern = #"(?:^[^"]*"|\G)[^"]*?\K(?<![" ])[A-Z]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.LabelText("ATextWhichHasCapitalLetters")
.Label(Constants.DefinedLabel)
.Label("AnotherTextWhichHasCapitalLetters")
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" $0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)