const regex = /^[\s\S]*(?:^|\r?\n)\s+(\d+)(?![\s\S]*(\r?\n){2})/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\s\\S]*(?:^|\\r?\\n)\\s+(\\d+)(?![\\s\\S]*(\\r?\\n){2})', 'm')
const str = `this is test
1. this is test
2. this is test
3. this is test
this is test
1. this test
2. this is test 5
this is test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}