re = /(?<!\S\S)\s+(?!\S\S)/m
str = 'A B C Company
XYZ Inc
S & K Co
A B C D E F G Company'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result