# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:http?:\\/\\/|https?:\\/\\/)?(?:www\.)?github\.com\\/(?:\\/*)([\w\-\.\\/]*)//gm;t' <<< "https://github.com/Chocksy"