package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\[|,|^)[\t ]*((?'type'[a-zA-Z0-9_.\[\]]+)(?:[\t ]*\|[\t ]*(?&type))+)(?:\]|,|$)`)
var str = `str|int|bool
int | tuple[str|int] | bool
Decimal|datetime.date|str
str|Optional[int]
Optional[int|str]
dict[str | int, list[B | C | Optional[D]]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}