package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-?(?:\d+(?:\.\d*)?|\.\d+)`)
var str = `-1234454.3435
-98.99
-12.9
-12.34
-10.001
-3
-0.001
-000
-0.00
0
0.00
00000001.1
0.01
1201.0000001
1234454.3435
7638.98701`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}