import Foundation
let pattern = #"((?:^|,\s).*?)(?=,\s\S+;|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"has_recent_activity=1; path=/; expires=Fri, 28 Dec 2018 09:07:30 -0000, logged_in=no; domain=.github.com; path=/; expires=Tue, 28 Dec 2038 08:07:30 -0000; secure; HttpOnly, _gh_sess=NG4xelVwV0JLV2ppUTVxQXArT2Y1TFRHdGlTanJ2QUwrV2t1MjVVZGF3eFk3Q2FsamJnVmNLdXZlanBRQzUrei9oSkl5WTY2ZkUzb04yQ1lReStNUHdVVWpwWXJUSmxGVmdleHIrU2ZNc3V0Y2FsZUpFb2Y1TnNTNExHYUg1a0x1dHhKZ3dLQ0lNWVEyenZEb2NoYnFaQ0l6VlBjNElQVkNNRHBBZlFmRDBlQmhXb0Q1Z0dKc2lUYlIvVHF4bVJwampPbjZnSDZ5MUV4YVozMmx5eDF3dz09LS1nNjZ5QWVMWlNiSlhsUUNqR0k4U2l3PT0%3D--bd93a324c5ca26bb447180edaa0029498908afb8; path=/; secure; HttpOnly"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)