import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\w\\-]=\"|\")(https?:\\/\\/[\\w\\-\\.!~?&=+\\*'(),\\/\\#\\:]+)((?!\\<\\/\\w\\>))*?";
final String string = "<a href=\"https://worldofwarships.ru/\">https://worldofwarships.ru/</a><div><br></div>\n\n"
+ "<div data-test=\"https://worldofwarships.ru/1\">https://worldofwarships.ru/1</div>\n\n"
+ "<div>https://worldofwarships.ru/0</div>\n\n"
+ "<div>https://worldofwarships.ru/0</div>\n\n"
+ "<div> https://worldofwarships.ru/2</div>\n\n"
+ "https://worldofwarships.ru/3?test=https://worldofwarships.ru/\n\n"
+ "https://worldofwarships.ru/4#https://worldofwarships.ru/\n\n"
+ "https://worldofwarships.ru/5\n\n"
+ "<div>https://worldofwarships.ru/3<br clear=\"all\">\n"
+ "<div><br></div>-- <br><div class=\"gmail_signature\"><div dir=\"ltr\">Тестовый аккаунт</div></div>\n"
+ "</div>\n\n"
+ "<img src=\"https://worldofwarships.ru/3?test=https://worldofwarships.ru/3\"/>\n"
+ "<img src=\"https://worldofwarships.ru/3#https://worldofwarships.ru/3\"/>\n\n"
+ "<form action=\"https://worldofwarships.ru/3\"></form>";
final String subst = "<a href=\"$1\">$1</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}