import Foundation
let pattern = #"- \(\w+\)(composeView\(.*?\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
- (void)composeView(...) gives func composeView(...)
+ (void)composeView(...) gives class func composeView(...)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"func \1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)