$re = '/[\\\\?&]([^&=]+)=([^&=]+)/i';
$str = '?at=FCoKtkupr0GgZCxuxr4zk8k4xaE5T2XIQzi8Dl9v84w=&palt=awesome';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);