using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(>\s+<)";
string substitution = @"><";
string input = @"<ul class=""list-group sidebar-nav-v1 margin-bottom-40"" id=""menuHomeUserPrivate"">
<li class=""list-group-item active"">
<a id=""to_ProfileOverall"" class=""privateMenuLinkJS""><i class=""fa fa-bar-chart-o""></i> Overall</a>
</li>
<li class=""list-group-item list-toggle"">
<a data-toggle=""collapse"" data-parent=""#menuHomeUserPrivate"" href=""#collapse-MoneyManage"" ><i class=""fa fa-money""></i> Invoice</a>
<ul id=""collapse-MoneyManage"" class=""collapse"">
<li><a id=""to_MoneyManagerFaturamentoInsert"" class=""privateMenuLinkJS""><i class=""fa fa-level-down""></i> Big Invoice </a></li>
<li><a id=""to_MoneyManagerFaturamentoGerir"" class=""privateMenuLinkJS""><i class=""fa fa-cogs""></i> Big big big
Invoice 2 </a></li>
</ul>
</li>
</ul>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}