import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(>\\s+<)";
final String string = "<ul class=\"list-group sidebar-nav-v1 margin-bottom-40\" id=\"menuHomeUserPrivate\"> \n"
+ " <li class=\"list-group-item active\">\n"
+ " <a id=\"to_ProfileOverall\" class=\"privateMenuLinkJS\"><i class=\"fa fa-bar-chart-o\"></i> Overall</a>\n"
+ " </li>\n"
+ " <li class=\"list-group-item list-toggle\">\n"
+ " <a data-toggle=\"collapse\" data-parent=\"#menuHomeUserPrivate\" href=\"#collapse-MoneyManage\" ><i class=\"fa fa-money\"></i> Invoice</a>\n"
+ " <ul id=\"collapse-MoneyManage\" class=\"collapse\">\n"
+ " <li><a id=\"to_MoneyManagerFaturamentoInsert\" class=\"privateMenuLinkJS\"><i class=\"fa fa-level-down\"></i> Big Invoice </a></li>\n"
+ " <li><a id=\"to_MoneyManagerFaturamentoGerir\" class=\"privateMenuLinkJS\"><i class=\"fa fa-cogs\"></i> Big big big\n"
+ " \n"
+ " Invoice 2 </a></li>\n"
+ " </ul>\n"
+ " </li>\n"
+ " </ul>";
final String subst = "><";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}