const regex = /^(?=(?:.*[a-zA-Z])+)([a-zA-Z\d]{10,30})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:.*[a-zA-Z])+)([a-zA-Z\\d]{10,30})$', 'gm')
const str = `1eeeeeeeee333e
eeeeeeeee333e
2222222222222
622222222522
123456789012q`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}