$re = '/^([0-4][\d](\.[0-5]*)?)$/';
$str = '30.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);