#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\\\\(\d+)\s+[\d\\]+$"
Local $sString = "\\0101 \\0102 \\0103 \\0104" & @CRLF & _
"\\0201 \\0202 \\0203 \\0204 \\0205 \\0206" & @CRLF & _
"\\0301 \\0302 \\0303 \\0304 \\0305 \\0306"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")