# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*<div class=\"new\">.*?href=\"((?:.*?)channel=(.*?))\".*?src=\"(.*?)\".*?</a>\s*</div>"
test_str = ("<div class=\"new\"> <a class=\"block\" target=\"_blank\" href=\"http://somesite:8080/hls/mango1.m3u8?token=34523sedfsdfsdf&e=123456789&channel=mango1\" data-toggle=\"modal\" data-target=\"#mango1\">\n"
"<div class=\"image-container\"> <img src=\"images/mango1.png\" class=\"img-responsive\" > </div>\n"
"</a> </div>\n\n"
" <div class=\"new\"> <a class=\"block\" target=\"_blank\" href=\"http://somesite:8080/hls/mango2.m3u8?token=sfaesfraesgh452342&e=987654321&channel=mango2\" data-toggle=\"modal\" data-target=\"#mango2\">\n"
"<div class=\"image-container\"> <img src=\"images/mango2.png\" class=\"img-responsive\" > </div>\n"
"</a> </div>")
subst = "HREF: \\1\\nCHANNEL: \\2\\nSRC: \\3\\n\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.