#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ";[^;.]*;"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Donec eget eros" & @CRLF & _
"libero. Duis ac diam pretium velit volutpat facilisis in vel nibh. In lacinia ; neque " & @CRLF & _
"massa, in consectetur lectus ; faucibus vel. Maecenas ; dapibus leo nec ; elit sagittis " & @CRLF & _
"convallis. Sed at lacus consectetur, eleifend urna tristique, consequat orci. Nullam " & @CRLF & _
"ac orci quis elit pellentesque consectetur quis ac libero. Duis lorem sem, sodales ; ut " & @CRLF & _
"massa sed, porta facilisis ex. Aliquam cursus accumsan ante sed maximus. "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)