# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r";[^;.]*;"
test_str = ("Lorem ipsum dolor sit amet, consectetur adipiscing elit. Donec eget eros\n"
"libero. Duis ac diam pretium velit volutpat facilisis in vel nibh. In lacinia ; neque \n"
"massa, in consectetur lectus ; faucibus vel. Maecenas ; dapibus leo nec ; elit sagittis \n"
"convallis. Sed at lacus consectetur, eleifend urna tristique, consequat orci. Nullam \n"
"ac orci quis elit pellentesque consectetur quis ac libero. Duis lorem sem, sodales ; ut \n"
"massa sed, porta facilisis ex. Aliquam cursus accumsan ante sed maximus. ")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.