// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r";[^;.]*;").unwrap();
let string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Donec eget eros
libero. Duis ac diam pretium velit volutpat facilisis in vel nibh. In lacinia ; neque
massa, in consectetur lectus ; faucibus vel. Maecenas ; dapibus leo nec ; elit sagittis
convallis. Sed at lacus consectetur, eleifend urna tristique, consequat orci. Nullam
ac orci quis elit pellentesque consectetur quis ac libero. Duis lorem sem, sodales ; ut
massa sed, porta facilisis ex. Aliquam cursus accumsan ante sed maximus. ";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}