import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/\\*(?>[^*]*(?:\\*+|\\z(*ACCEPT)))+?/";
final String string = " abc /* hi */ def /* h*i */\n\n"
+ "ghi /* dfg*df*g d *fd g*dfg**fdgdfgfdg dfg dfg fdg dfg df\n"
+ "dfg dfg dfg \n"
+ "dfg dfg df\n"
+ "g df gdfg */\n\n"
+ "ghi /* dfg*df*g d *fd g*dfg**fdgdfgfdg dfg dfg fdg dfg df\n"
+ "dfg dfg dfg \n"
+ "dfg dfg df\n"
+ "g df gdfg ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}