#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=ab|cd|ef|gh) *}} *{{ *(?=ab|cd|ef|gh)"
Local $sString = "{{ab}}{{ cd }}{{ ef }} {{ gh }} {{ gh }}{{ghen web|url=tr.uc}}" & @CRLF & _
"machintrcd}} {{ab}} {{cd}}" & @CRLF & _
"{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}" & @CRLF & _
"{{ab}} {{ab}} {{ab}} {{ab}} {{ab}} {{ab}}" & @CRLF & _
"machintruc {{ab}} {{cd}}" & @CRLF & _
"{{ab}} {{cd}} {{ef}} [https://truc.org truc]" & @CRLF & _
"{{mr}} Trucmuche"
Local $sSubst = "|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)