#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "-val1-([^-]+)(?:-val2-([^-]+)|)(?:-val3-([^-]+)|)-"
Local $sString = "-val1-test-val2-result-val3-done-" & @CRLF & _
"-val1-test-val3-done-" & @CRLF & _
"-val1-test-val2-res-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")