const regex = /-val1-([^-]+)(?:-val2-([^-]+)|)(?:-val3-([^-]+)|)-/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-val1-([^-]+)(?:-val2-([^-]+)|)(?:-val3-([^-]+)|)-', 'g')
const str = `-val1-test-val2-result-val3-done-
-val1-test-val3-done-
-val1-test-val2-res-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}