use strict;
my $str = '2,000,000
200000.0000
200
200.00000
2,000.00
1000,000
1,000000
2,000,000
200000.0000
200
200.00000
2,000.00
2,0,00.00
1,234,456.7890
0900
0.88
0
890';
my $regex = qr/^(([1-9]\d*(\,\d+)*(\.\d{1,4})?)|(0\.\d{1,4})|0)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}