using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*\d*\:)?(\w+\.+\w..$)";
string substitution = @"$2";
string input = @"*:443:domain.com
*:443:www.domain.com
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}