$re = '/(.*\d*\:)?(\w+\.+\w..$)/m';
$str = '*:443:domain.com
*:443:www.domain.com
';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;