using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Action by .*\, (.*)\. (?<team1>.*)( \d+\,) (?<team2>.*)(\d+\.)";
string input = @"Action by Toni Kroos, Real Madrid. Rayo Vallecano 2, Real Madrid 0.
Action by Toni Kroos, Real Madrid. Real Madrid 0, Rayo Vallecano 2.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}