const regex = new RegExp('\\AX{2}-X{6}$\\z|\\A(C?((0[1-9])|(1[0-2])))-[0-4][0-9A-Z]{4}[14]\\z', '')
const str = `XX-XXXXXX`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}